Firefox and Reading Assistant

Reading Assistant technology requires that the Firefox browser accept plug-ins. Starting on March 7, 2017, Firefox will begin phasing out plug-in support. See blog.mozilla.org for details.

To let your students continue using Firefox with Reading Assistant after that date, you’ll need to switch to the Firefox Extended Support Release browser on their Windows or Macintosh computers. Note that Reading Assistant does not support 64-bit browsers, so avoid downloading the Windows 64-bit installer for Firefox ESR.

Alternatively, your students can use another supported browser with Reading Assistant. See Basic client requirements for a complete list.

If you have any questions or concerns, contact Scientific Learning Customer Support.